Solved Error installing rails: i18n requires Ruby version >= 1.9.3


I was trying to install rails on CentOS operating system, I got the error Error installing rails: i18n requires Ruby version >= 1.9.3.

Solution: Update the Rails Version

Execute following commands:

yum groupinstall -y development
curl -L get.rvm.io | bash -s stable

  
Error installing rails: i18n requires Ruby version >= 1.9.3

I again received following error: GPG signature verification failed for '/usr/local/rvm/archives/rvm-1.

To solve it curl -sSL https://rvm.io/mpapis.asc | gpg2 –import – in terminal


gpg: key D39DC0E3: public key "Michal Papis (RVM signing) <mpapis@gmail.com>" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)

-------------------------------
Run the following command again curl -L get.rvm.io | bash -s stable
It will install RVM to /usr/local/rvm/

Once execution in successfully completed, execute following command in Terminal:

source /etc/profile.d/rvm.sh
rvm install 1.9.3

If you get following Error:

GPG key retrieval failed: [Errno 14] 
Could not open/read file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag

Run following command in terminal:
rpm –import http://apt.sw.be/RPM-GPG-KEY.dag.txt


Now, once all errors are solved run following command again:

rvm install 1.9.3

Now check the ruby version by running below command:

ruby --version

DONE!

Leave a comment

Your email address will not be published. Required fields are marked *